TECHNICAL PAPER

Installing & Configuring UNICOM® System Architect®

Part 2 of 2: Connecting to Microsoft® SQL Server®

by Sami Joueidi
Senior Cloud Architect
IBM
Contents
Executive Summary ........................................................................................................................................5
Overview of System Architect ..................................................................................................................5
Preparation Tasks .....................................................................................................................................6
Prerequisite Tasks .....................................................................................................................................6
System Architect Administrator Tasks ......................................................................................................6
Network or Domain Engineer Tasks .........................................................................................................7
SQL Server Database Administrator Tasks ..............................................................................................7
Configure SA to Connect to the SQL Server ............................................................................................8
Create New Encyclopedia on the SQL Server Instance ...........................................................................9
Create a Database User Role ...................................................................................................................9
Assign the User Role to the saUsersGroup .............................................................................................10
Connect System Architect to the SQL Server ..........................................................................................12
Configure Other Workstations ................................................................................................................13
Open an Existing Encyclopedia ................................................................................................................13
Basic Troubleshooting ............................................................................................................................14
Enable remote connections for the SQL server .......................................................................................14
Enable the SQL server browser service ....................................................................................................14
Create Exceptions in Windows XP and Windows Server 2003 Firewall ..............................................15
Create an Exception for SQL Server Browser Service for Firewall ....................................................16
Open a Port in the Firewall for TCP access .............................................................................................16
Open a Port in the Firewall for the Browser Service ..............................................................................16
Resources ................................................................................................................................................17
Learn .....................................................................................................................................................17
Discuss ..................................................................................................................................................17
Executive Summary

This is Part 2 of a 2-part series. This article guides you through the steps to connect UNICOM® System Architect® (SA) to a ‘full blown’ Microsoft® SQL Server® environment, whereas Part 1 guided you through installing System Architect with Microsoft® SQL Server Express®.

Installing and configuring UNICOM® System Architect® is typically straightforward with a one-click install that provides installation of the product and an underlying Microsoft® SQL Server Express database. However, Windows security can provide some challenges for installation of Microsoft SQL Server to a Windows environment. Further complexities may be encountered if you are installing System Architect to a network environment and using a separately installed version of ‘full-blown’ Microsoft® SQL Server. This later scenario is covered in this article, for System Architect version 11.4.4 or later. The example used is targeted for professional encyclopedias, which are one of the two types of repositories in System Architect.

Overview of System Architect

System Architect is a comprehensive enterprise architecture solution that provides fully integrated support across four key domains: business, information, systems, and technology. It is used to capture complex knowledge about organizations and related technology.

Empowered with this knowledge, executives, decision makers, and managers can analyze and optimize current capabilities, because they will have a more thorough understanding of the organizational structures, portfolio of business strategies, business processes, information flow, applications, and technology infrastructure. The result is an enhanced collaboration between stakeholders and improvement in the organization’s effectiveness to proactively respond to business changes and an enhanced ability to consider new capabilities.

In addition, System Architect is the most widely used enterprise architecture solution in support of the U.S. Department of Defense Architecture Framework (DoDAF). It provides the capabilities for building models representing U.S. Department of Defense (DoD) architectures and automatically generates DoDAF work products and reports.

System Architect includes the Federal Enterprise Architecture Framework (FEAF) that assists the U.S. Government departments and agencies in incorporating and using the U.S. Office of Management and Budget (OMB) Reference Models, as well as the subsequent creation and publishing of OMB Exhibit 300 and Exhibit 53 reports.
Preparation Tasks

This article is based on these three assumptions:

1. That System Architect is installed and configured on the workstation as described in Part 1 of this article series, *Installing and Configuring UNICOM® System Architect® – Stand-Alone Installation with Microsoft® SQL Server Express®*.

2. That a Microsoft® SQL Server® is already installed and an instance is created.

3. That Microsoft® Windows® authentication is used to access the SQL Server instance.

Connecting System Architect to a SQL server instance involves specific tasks to be completed by the network or domain administrator, the database administrator, and the System Architect administrator. The following sections describe these tasks by role.

Prerequisite Tasks

Ensure that System Architect is installed and configured on the workstations. See the following sections in Part I (*Installing and Configuring UNICOM® System Architect® – Stand-Alone Installation with Microsoft® SQL Server Express®*) to ensure proper installation and configuration:

- Section I: Install UNICOM License Server (to network server)
- Section II: Install System Architect (to network workstation)
- Section IV: Create a Shared Folder for Encyclopedia Backups

System Architect Administrator Tasks

1. Identify all or most System Architect users (you can add users later).

2. Collect their user domain login IDs.

3. Get answers to these questions:
   - Which users will be System Architect administrators? These users can create, manage, and set up user access to System Architect encyclopedias.
• Which users are standard System Architect users? These people use SA daily.

4. Provide this information to the network or domain engineer.

Network or Domain Engineer Tasks

1. Create two Windows domain groups:
   • saAdminGroup
   • saUsersGroup

2. Add the following domain users (format: <domain>\<username>) to these groups:
   • Add the System Architect administrator users to the saAdminGroup.
   • Add both System Architect Administrator users and System Architect standard users to the saUsersGroup.

3. Verify that the System Architect workstations have network access to the SQL server (hostname) and set up the exceptions in Windows Firewall to allow remote access to the SQL instance, if required.

SQL Server Database Administrator Tasks

1. Identify the SQL instance where System Architect encyclopedias (databases) will be created.

2. Provide the SQL instance name to the System Architect administrators in the form of hostname\instance name.

3. Provide the port number to the System Architect administrators in case SQL server is not using the standard port.

4. Ensure that the proper SQL services are running on the SQL server to allow remote access to the SQL instance.

5. Add both the saAdminGroup and saUsersGroup groups to the SQL server instance.

6. Assign the dbcreator server role to the saAdminGroup.

Note:
The domain users that are part of the saAdminGroup must be able to create System Architect encyclopedias (by using the System Architect Encyclopedia Manager (SAEM) tool that is included). They are, in essence, the database owners of these encyclopedias.
Configure SA to Connect to the SQL Server

Open the Startup Wizard and configure System Architect:

1. Log in to the workstation as the System Architect administrator.
3. Select Help > Startup Wizard if the wizard did not start automatically.
4. In the Welcome screen, click Next.
5. Uncheck the Configure sample and tutorial encyclopedia projects check box.

![Select options to configure (select an option to view its description):](image)

*Figure 1. Select options for System Architect configuration*

6. Click Next.
7. Select the option that says **Existing SQL Server located on the network** (Figure 2)

![Configure Where Encyclopedia Data Will Be Stored](image)

*Figure 2. Specify where to store encyclopedia data*

8. Select the SQL server instance given to you by your database administrator, in this format:

```
hostname\instance name.
```
9. Click **Next**.
10. If asked, select **Windows Authentication** from the Connection Information window.
11. Navigate through the screens and complete the configuration.

**Create New Encyclopedia on the SQL Server Instance**

1. Log in to the workstation as System Architect Administrator (a user who belongs to the saAdminGroup).
3. Click **File > Open Encyclopedia**.
4. Click **New** to create a new encyclopedia.
5. Under Connection, click the browse button (three dots) to create a new connection.
6. Click **New** to create a new connection.
7. For a connection name, type the SQL server instance name.
8. Select **hostname\instance name** from the drop-down list for a server name.
9. Click **OK**.
10. In the Open Encyclopedia window, enter a name for the new Rational System Architect Encyclopedia (for example: test).
11. Click **OK**.

**Create a Database User Role**

Logins names are server-wide accounts that can be mapped to individual users or user groups. A login name for a System Architect user needs a predefined set of server roles and database access rights. To make it easy to grant Rational System Architect users the required privileges, the Encyclopedia Manager feature provides the "Create SAUser Role" function under the Tools menu. This database role is defined with the minimum rights needed by a user to access System Architect encyclopedias. Basically, it gives the user **databasereader** and **databasewriter** access (these are predefined database roles), as well as EXEC rights on any stored procedures used by System Architect.
1. From the **Start** menu select **All Programs** > **UNICOM Systems** > **UNICOM Systems Lifecycle Solutions** > **System Architect** > **SAEM for SQL Server**.

2. Click **Server** > **Connect** to create a connection to the SQL instance.

3. From the drop-down menu, select the SQL server instance, which is in the form of `hostname\instance name`.

4. Select **Windows** for authentication.

5. Press **OK** to create a connection to the SQL server instance.

6. Select the **test** database from the drop-down menu in the database toolbar, as Figure 3 shows.

   **Note:** A database must be selected to be able to issue any commands in Software Architect Encyclopedia Manager.

   ![Encyclopedia Manager](image)

   **Figure 3. Select an encyclopedia**

7. Click **Tools** > **Create SAUser Role** from the drop-down menu.

**Assign the User Role to the saUsersGroup**

1. Click **Server** > **Logins** to see a list of login groups or users that are available.

2. Select **saUserGroup** from the list.

3. Click the icon to edit the selected login group.
Figure 4. Select the saUserGroup from the list

4. Click the Database Access tab.

5. In the "Specify which database can be accessed by this login" pane, click the check box for the test database (see Figure 5).

Figure 5. Database Access tab in Login Properties view

6. Click OK to switch to the Logins window.

7. Select saUserGroup from the list again.

8. Click the Edit icon to edit the selected login name.

9. Click the Database Access tab.

10. Click the test database. This time, the roles are displayed.

11. Check the SAUser (see Figure 6, lower part).
12. Click **OK** and close the Login Properties window.

13. Click **Servers > Disconnect** to disconnect from the SQL server instance.

14. Exit the Encyclopedia Manager (SQL server) utility.

**Connect System Architect to the SQL Server**

1. Log off of the workstation as the System Architect administrator.
2. Log in to the workstation as a standard System Architect user (the user part of the saUsersGroup).
4. Click **Help > Startup Wizard** if it is not already started.
5. Click **Next** in the Startup Wizard.
6. Click **Next** to accept the default.
7. Select the option to **Existing SQL Server Located** the network.
8. Select the SQL Server **hostname\instance name**.
9. Click **Next**.
10. From the Connection Information window, select **Windows Authentication**.
11. Navigate through the rest of the screens and complete the configuration.

**Configure Other Workstations**

Repeat the process described here on each System Architect workstation:

2. Launch the Startup Wizard if it is not already started.
3. Connect to the SQL server Instance as described previously.
4. Open the existing encyclopedia.
5. Repeat the process for additional workstations.

**Open an Existing Encyclopedia**

1. Start System Architect if not already started.
2. Click **File > Open Encyclopedia** to get the Open Encyclopedia view.
3. Click **Existing** to view existing encyclopedias.
4. Open the encyclopedia that interests you.
Basic Troubleshooting

Instructions follow for the situations that you are most likely to use or encounter.

Enable remote connections for the SQL server

You must enable remote connections the SQL server instance. Follow these steps:

1. Click Start > Programs > Microsoft SQL Server 2005 > Configuration Tools.
2. Click SQL Server Surface Area Configuration.
3. On the SQL Server 2005 Surface Area Configuration page, click Surface Area Configuration for Services and Connections.
4. Expand Database Engine.
5. Click Remote Connections.
6. Click Local and remote connections.
7. Click the appropriate protocol to enable for your environment.
8. Click Apply.
9. Click OK when you receive the following message:
   Changes to Connection Settings will not take effect until you restart the Database Engine service.
12. Click Service.
13. Click Stop, and wait until the MSSQLSERVER service stops.
14. Click Start to restart the MSSQLSERVER service.

Enable the SQL server browser service

Caution

By enabling SQL Server Browser service, you are increasing your security risk and making your workstation and network more vulnerable to attack by malicious users or by malicious software such as viruses. If you choose to do so anywhere, follow these steps:
1. Click **Start** > **Programs** > Microsoft **SQL Server 2005** > **Configuration Tools**.
2. Click **SQL Server Surface Area Configuration**.
3. On the **SQL Server 2005 Surface Area Configuration** page, click **Surface Area Configuration for Services and Connections**.
4. Click **SQL Server Browser**.
5. For "Startup type," select **Automatic**.
6. Click **Apply**.
7. Click **Start**.
8. Click **OK**.

**Create Exceptions in Windows XP and Windows Server 2003 Firewall**

To open Microsoft Windows Firewall:

1. Click **Start**.
2. Click **Run**.
3. Type `firewall.cpl`.
4. Click **OK**.
5. Click the **Exceptions** tab in Windows Firewall.
6. Click **Add Program**.
7. Click **Browse** in the Add a Program window.
8. Click the `C:\Program Files\Microsoft SQL Server\<instance id>\MSSQL\Bin\sqlservr.exe` executable program or the path where the SQL server 2005 is installed.
9. Click **Open**.
10. Click **OK**.
Create an Exception for SQL Server Browser Service for Firewall

1. Click the Exceptions tab in Windows Firewall.
2. Click Add Program.
3. Click Browse.
4. Click the C:\Program Files\Microsoft SQL Server\90\Shared\sqlbrowser.exe executable program.
5. Click Open.
6. Click OK.

Open a Port in the Firewall for TCP access

1. In the Control Panel, open Network Connections.
2. Right-click the active connection.
4. Select the Advanced tab.
5. Click Windows Firewall Settings.
6. In the Windows Firewall window, click the Exceptions tab.
7. Click Add Port.
8. In the Name text box of the Add a Port window, type SQL Server <instance name>.
9. Type the port number of the database instance (for example: 1433) for the default instance.
10. Verify that TCP is selected.
11. Click OK.

Open a Port in the Firewall for the Browser Service

1. Click Add Port, type SQL Server Browser in the Name text box, and then type 1434 in the Port Number text box.
2. Select UDP.
3. Click OK.
Resources

Learn

- Learn more about UNICOM® System Architect®:
  - Watch videos of UNICOM® System Architect® on its YouTube channel, SystemArchitectTrain.

Discuss

- Participate in the System Architect LinkedIn forum, where you can share information about methods, frameworks, and tool implementations. Discussions include tool-specific technical discussions about System Architect.
- Follow UNICOM® System Architect® on:
  - Facebook.com\SystemArchitect,
  - Twitter (@SystemArchitect), and
  - YouTube (SystemArchitectTrain),

and add your comments and requests.